summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-12-01 19:37:08 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-12-01 19:37:08 (GMT)
commite0eb3d02966066761d1723752cc0d0c586ade707 (patch)
tree9d7922332c3aafc6e7343a9614b5fbb281d28a6b /src/CMakeLists.txt
parent585cf69c56ea3411c0e661ad71b208ecac7732a7 (diff)
downloadhdf5-e0eb3d02966066761d1723752cc0d0c586ade707.zip
hdf5-e0eb3d02966066761d1723752cc0d0c586ade707.tar.gz
hdf5-e0eb3d02966066761d1723752cc0d0c586ade707.tar.bz2
H5detect and H5make_libsettings need include folder
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b163b8a..ab06ce8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -849,6 +849,9 @@ endif ()
#-----------------------------------------------------------------------------
add_executable (H5detect ${HDF5_SRC_DIR}/H5detect.c)
TARGET_C_PROPERTIES (H5detect STATIC " " " ")
+if (H5_HAVE_PARALLEL AND MPI_C_FOUND)
+ target_include_directories (H5detect PUBLIC ${MPI_C_INCLUDE_DIRS})
+endif ()
if (MSVC OR MINGW)
target_link_libraries (H5detect "ws2_32.lib")
endif ()
@@ -863,6 +866,9 @@ add_custom_command (
add_executable (H5make_libsettings ${HDF5_SRC_DIR}/H5make_libsettings.c)
TARGET_C_PROPERTIES (H5make_libsettings STATIC " " " ")
+if (H5_HAVE_PARALLEL AND MPI_C_FOUND)
+ target_include_directories (H5make_libsettings PUBLIC ${MPI_C_INCLUDE_DIRS})
+endif ()
if (MSVC OR MINGW)
target_link_libraries (H5make_libsettings "ws2_32.lib")
endif ()