summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-12-04 19:07:01 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-12-04 19:07:01 (GMT)
commitf09bfdb490ee31a29cb14f3692b66b8396d9ed80 (patch)
tree29c9d8b60d035fdb27181a043fc503493dde7df1 /src/CMakeLists.txt
parente0eb3d02966066761d1723752cc0d0c586ade707 (diff)
downloadhdf5-f09bfdb490ee31a29cb14f3692b66b8396d9ed80.zip
hdf5-f09bfdb490ee31a29cb14f3692b66b8396d9ed80.tar.gz
hdf5-f09bfdb490ee31a29cb14f3692b66b8396d9ed80.tar.bz2
Change reference from dl to CMake variable
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ab06ce8..1d217c6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -891,7 +891,7 @@ add_library (${HDF5_LIB_TARGET} STATIC ${common_SRCS} ${gen_SRCS} ${H5_PUBLIC_HE
TARGET_C_PROPERTIES (${HDF5_LIB_TARGET} STATIC " " " ")
target_link_libraries (${HDF5_LIB_TARGET} PRIVATE ${LINK_LIBS} ${LINK_COMP_LIBS})
if (NOT WIN32)
- target_link_libraries (${HDF5_LIB_TARGET} PUBLIC dl)
+ target_link_libraries (${HDF5_LIB_TARGET} PUBLIC ${CMAKE_DL_LIBS})
endif ()
if (H5_HAVE_PARALLEL AND MPI_C_FOUND)
target_include_directories (${HDF5_LIB_TARGET} PUBLIC ${MPI_C_INCLUDE_DIRS})
@@ -935,7 +935,7 @@ if (BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (${HDF5_LIBSH_TARGET} SHARED " " " ")
target_link_libraries (${HDF5_LIBSH_TARGET} PRIVATE ${LINK_LIBS} ${LINK_COMP_LIBS})
if (NOT WIN32)
- target_link_libraries (${HDF5_LIBSH_TARGET} PUBLIC dl)
+ target_link_libraries (${HDF5_LIBSH_TARGET} PUBLIC ${CMAKE_DL_LIBS})
endif ()
if (H5_HAVE_PARALLEL AND MPI_C_FOUND)
target_include_directories (${HDF5_LIBSH_TARGET} PUBLIC ${MPI_C_INCLUDE_DIRS})