summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-01-27 21:45:23 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-01-27 21:45:23 (GMT)
commit1454a458262dd012c94f56ccc55ccbbe57b63399 (patch)
tree3924efe3b45657d02b8dcc394df30626591a6610 /src/CMakeLists.txt
parent7afa7bb6afd1cf4daee58010e4f9411262abeab9 (diff)
downloadhdf5-1454a458262dd012c94f56ccc55ccbbe57b63399.zip
hdf5-1454a458262dd012c94f56ccc55ccbbe57b63399.tar.gz
hdf5-1454a458262dd012c94f56ccc55ccbbe57b63399.tar.bz2
[svn-r28996] Autotools configure updates to allow separation of build type, debug
symbols, asserts, profiling, and optimization. Also much refactoring, improved help, and --enable-<foo> options will now emit errors on nonsense (e.g.: --enable-foo="asdfasdf"). The libhdf5.settings.in file was also reformatted. Tested on: 64-bit Ubuntu 15.10 (Linux 4.2.0 x86_64) gcc 5.2.1 serial and parallel autotools w/ various options
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8b90cd5..60f043f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -856,7 +856,7 @@ set_target_properties (${HDF5_LIB_TARGET} PROPERTIES
INTERFACE_INCLUDE_DIRECTORIES "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
)
-option (HDF5_ENABLE_DEBUG_APIS "Turn on debugging in all packages" OFF)
+option (HDF5_ENABLE_DEBUG_APIS "Turn on extra debug output in all packages" OFF)
if (HDF5_ENABLE_DEBUG_APIS)
set_target_properties (${HDF5_LIB_TARGET} PROPERTIES
COMPILE_DEFINITIONS