summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-03-24 21:00:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-03-24 21:00:34 (GMT)
commit63e1b32068fb84f5d4a4bff2fc06a2801f141054 (patch)
tree8fddcd93cbe6e361cdacd29259d2aa5a3024f76e /src/CMakeLists.txt
parent810285be8ea039c1ab68e981abe5fbb5b8c40244 (diff)
downloadhdf5-63e1b32068fb84f5d4a4bff2fc06a2801f141054.zip
hdf5-63e1b32068fb84f5d4a4bff2fc06a2801f141054.tar.gz
hdf5-63e1b32068fb84f5d4a4bff2fc06a2801f141054.tar.bz2
[svn-r24886] Fix fortran mod file handling and packing
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 58f4732..ce1c725 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -838,6 +838,9 @@ target_link_libraries (${HDF5_LIB_TARGET} ${LINK_LIBS})
if (NOT WIN32)
target_link_libraries (${HDF5_LIB_TARGET} dl)
endif (NOT WIN32)
+if (H5_HAVE_PARALLEL AND MPI_C_FOUND)
+ target_link_libraries (${HDF5_LIB_TARGET} ${MPI_C_LIBRARIES})
+endif (H5_HAVE_PARALLEL AND MPI_C_FOUND)
set_global_variable (HDF5_LIBRARIES_TO_EXPORT ${HDF5_LIB_TARGET})
H5_SET_LIB_OPTIONS (${HDF5_LIB_TARGET} ${HDF5_LIB_NAME} ${LIB_TYPE})
set_target_properties (${HDF5_LIB_TARGET} PROPERTIES