summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-01-27 20:51:40 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-01-27 20:51:40 (GMT)
commit7afa7bb6afd1cf4daee58010e4f9411262abeab9 (patch)
treea2c5ed68e81536fa78269128e3c10274e4752299 /src/CMakeLists.txt
parent7abd70b809d1ee24d697520030587022c7b8d4e7 (diff)
downloadhdf5-7afa7bb6afd1cf4daee58010e4f9411262abeab9.zip
hdf5-7afa7bb6afd1cf4daee58010e4f9411262abeab9.tar.gz
hdf5-7afa7bb6afd1cf4daee58010e4f9411262abeab9.tar.bz2
[svn-r28995] Removed unused packages from list in --enable-debug=<pkgs> configure
option (also updated CMake). Tested on: 64-bit Ubuntu 15.10 (Linux 4.2.0 x86_64) gcc 5.2.1 serial autotools serial CMake (CMake 3.3.2)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2c9ca8a..8b90cd5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -860,7 +860,7 @@ option (HDF5_ENABLE_DEBUG_APIS "Turn on debugging in all packages" OFF)
if (HDF5_ENABLE_DEBUG_APIS)
set_target_properties (${HDF5_LIB_TARGET} PROPERTIES
COMPILE_DEFINITIONS
- "H5Z_DEBUG;H5VM_DEBUG;H5T_DEBUG;H5S_DEBUG;H5P_DEBUG;H5O_DEBUG;H5MM_DEBUG;H5MF_DEBUG;H5I_DEBUG;H5HL_DEBUG;H5HG_DEBUG;H5G_DEBUG;H5F_DEBUG;H5E_DEBUG;H5D_DEBUG;H5B_DEBUG;H5AC_DEBUG"
+ "H5Z_DEBUG;H5T_DEBUG;H5ST_DEBUG;H5S_DEBUG;H5O_DEBUG;H5I_DEBUG;H5HL_DEBUG;H5F_DEBUG;H5D_DEBUG;H5B2_DEBUG;H5B_DEBUG;H5AC_DEBUG"
)
endif (HDF5_ENABLE_DEBUG_APIS)
set (install_targets ${HDF5_LIB_TARGET})