summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-06-06 19:23:59 (GMT)
committerGitHub <noreply@github.com>2023-06-06 19:23:59 (GMT)
commit3c05dd74b865135ee7b0dcf0c38d5df85c6d95d8 (patch)
tree0ca6fc1d353505daebfe7813d17f05053f52bd9c /src/CMakeLists.txt
parent2384a731763a7ceb11e39d48cc0f6991d908389e (diff)
downloadhdf5-3c05dd74b865135ee7b0dcf0c38d5df85c6d95d8.zip
hdf5-3c05dd74b865135ee7b0dcf0c38d5df85c6d95d8.tar.gz
hdf5-3c05dd74b865135ee7b0dcf0c38d5df85c6d95d8.tar.bz2
Move encode/decode macros to a new header (#3040)
Moves the file-independent encode and decode macros to a new H5encode.h header that is itself included in H5private.h. Removes UINT64ENCODE_VARLEN and UINT64DECODE_VARLEN, which were unused. Fixes include statements in files where H5VMprivate.h and H5MMprivate.h were included via H5Fprivate.h.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fc21eac..d644b02 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -17,6 +17,7 @@ set (H5_SOURCES
set (H5_HDRS
${HDF5_SRC_DIR}/hdf5.h
${HDF5_SRC_DIR}/H5api_adpt.h
+ ${HDF5_SRC_DIR}/H5encode.h
${HDF5_SRC_DIR}/H5public.h
#${HDF5_SRC_DIR}/H5version.h
#${HDF5_SRC_DIR}/H5overflow.h