summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-11-03 16:42:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-11-03 16:42:09 (GMT)
commitc812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd (patch)
tree79245efc0218e670e8c5edd9eb0d57ad045f0633 /src/Makefile.am
parentdc47bb7084d55993a0a6f3725dcf79d92d7f0e65 (diff)
downloadhdf5-c812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd.zip
hdf5-c812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd.tar.gz
hdf5-c812f3fea2c9bacfc0f2d2bcad6960e9aa640dcd.tar.bz2
Add doxygen auotoconf and cmake support
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a333220..8645e9d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,7 +18,7 @@
include $(top_srcdir)/config/commence.am
include $(top_srcdir)/config/lt_vers.am
-
+include $(top_srcdir)/config/doxygen.am
# How to build H5detect for number format detection.
# Use -g to force no optimization since many compilers (e.g., Intel) takes
@@ -33,7 +33,7 @@ lib_LTLIBRARIES=libhdf5.la
libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
# H5Tinit.c and H5lib_settings.c are generated files and should be cleaned.
-MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c
+MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c $(DX_CLEANFILES)
# H5pubconf.h is generated by configure, and should be cleaned.
DISTCLEANFILES=H5pubconf.h
@@ -201,6 +201,15 @@ $(top_srcdir)/src/H5version.h: $(top_srcdir)/src/H5vers.txt
$(top_srcdir)/src/H5overflow.h: $(top_srcdir)/src/H5overflow.txt
perl $(top_srcdir)/bin/make_overflow $?
+# doxygen support
+doxygen:
+ rm -fr $(top_builddir)/hdf5lib_docs
+ env $(DX_ENV) \
+ PROJECT_NAME="HDF5" \
+ SRCDIR=$(top_srcdir) \
+ OUTPUTDIR=$(top_builddir)/hdf5lib_docs \
+ $(DX_DOXYGEN) $(top_builddir)/$(DX_CONFIG)
+
# Add TRACE macros to library source files. This is done via the trace script
# in the hdf5/bin directory. If the file contains HDF5 API macros, a "clean"
# version of the source file is saved with a tilde (~) after its name and