summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 19:51:57 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 19:51:57 (GMT)
commit1abb6b133b54af0cdfa277b4f12304d3e88331bf (patch)
treeb9d31d2a4cf59e1ff6b25affb094e308eb864b26 /src/Makefile.am
parent9a1a404e5abab4dbff5a96de5983e93e2a419ec6 (diff)
downloadhdf5-1abb6b133b54af0cdfa277b4f12304d3e88331bf.zip
hdf5-1abb6b133b54af0cdfa277b4f12304d3e88331bf.tar.gz
hdf5-1abb6b133b54af0cdfa277b4f12304d3e88331bf.tar.bz2
[svn-r17571] Purpose:
Makefile Bug Fix Description: Added $(EXEEXT) extension to H5detect when it's executed to generate H5Tinit.c so it works correctly on platforms that require the full extension when running executables. Tested: h5committest, mingw, and user-verified (via submitted patch).
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fb73bbf..eb31afb 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -127,7 +127,7 @@ settings_DATA=libhdf5.settings
H5Tinit.c: H5detect$(EXEEXT)
LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
sed -e 's/-L/:/g' -e 's/ //g'`" \
- $(RUNSERIAL) ./H5detect > H5Tinit.c || \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > H5Tinit.c || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)