summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-04-21 19:17:15 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-04-21 19:17:15 (GMT)
commit1d9ab42c5716533e9bf58c678a5c8de1ede3f0a8 (patch)
treea39530f213e53c37c1e618280342889ebedcb4a1 /src/Makefile.am
parentea51b2e095c2ffeedc8bb7fee7dd373905e1806d (diff)
downloadhdf5-1d9ab42c5716533e9bf58c678a5c8de1ede3f0a8.zip
hdf5-1d9ab42c5716533e9bf58c678a5c8de1ede3f0a8.tar.gz
hdf5-1d9ab42c5716533e9bf58c678a5c8de1ede3f0a8.tar.bz2
Add a second bool argument to H5F_vfd_swmr_writer_end_of_tick() that
tells whether the call may wait for the reader tick to catch up. Add stub routines vfd_swmr_writer_may_increase_tick_to() and vfd_swmr_reader_did_increase_tick_to() for tests---e.g., vfd_swmr_zoo_writer/_reader---to use to coordinate their tick numbers. vfd_swmr_writer_may_increase_tick_to(new_tick, wait_for_reader) returns true if the writer may increase its tick number to `new_tick` without overrunning the reader. A reader uses vfd_swmr_reader_did_increase_tick_to() to tell a writer that its tick number has increased.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f26580b..b5d3e04 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -67,7 +67,7 @@ libhdf5_la_SOURCES= H5.c H5checksum.c H5dbg.c H5system.c H5timer.c H5trace.c \
H5FDhdfs.c \
H5FDint.c \
H5FDlog.c \
- H5FDvfd_swmr.c \
+ H5FDvfd_swmr.c H5FDvfd_swmr_instr.c \
H5FDmulti.c H5FDsec2.c H5FDspace.c H5FDstdio.c H5FDtest.c \
H5FL.c H5FO.c H5FS.c H5FScache.c H5FSdbg.c H5FSint.c H5FSsection.c \
H5FSstat.c H5FStest.c \