summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2020-07-10 20:09:29 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-07-10 20:09:29 (GMT)
commit2e66b5cf86c1a184e01eea6b67b52ac82648573a (patch)
tree6cf56f85fdc4f2b433a127d1c8d4d66dc59a8e65 /src/Makefile.am
parent5493f4faacd7984bf8e442786a33e49598118788 (diff)
downloadhdf5-2e66b5cf86c1a184e01eea6b67b52ac82648573a.zip
hdf5-2e66b5cf86c1a184e01eea6b67b52ac82648573a.tar.gz
hdf5-2e66b5cf86c1a184e01eea6b67b52ac82648573a.tar.bz2
Add all extant virtual files to a list. Add an "exclusive owner" (`exc_owner`)
member to all virtual files. Add a routine, H5FD_has_conflict(), that returns true if a new virtual file is identical to an existing virtual file that has an exclusive owner. Establish an exclusive owner for a VFD SWMR virtual file's lower virtual file. Rename bsdqueue.h to H5queue.h and install it, since it's used by H5FDpublic.h. This is part of a changeset that helps us avoid creating multiple H5F_shared_t for one file when virtual datasets are used with VFD SWMR. The old code for deduplicating VFD SWMR H5F_shared_t instances did not work correctly with VFD SWMR, so we'd end up with multiple H5F_shared_t all active on the same file.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d917c3e..cb3fa3c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -139,7 +139,9 @@ if ROS3_VFD_CONDITIONAL
endif
# Public headers
-include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h H5version.h \
+include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h \
+ H5queue.h \
+ H5version.h \
H5Apublic.h H5ACpublic.h \
H5Cpublic.h H5Dpublic.h \
H5Epubgen.h H5Epublic.h H5ESpublic.h H5Fpublic.h \