summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDhvanil Popat <dpopat@hdfgroup.org>2019-06-25 01:40:07 (GMT)
committerDhvanil Popat <dpopat@hdfgroup.org>2019-06-25 01:40:07 (GMT)
commit5d954a0214fa92aec884cdbccab10632a925fc08 (patch)
treee0f7ec80bb373be7685f4b38c1e7ccdd5902c1b1 /src/Makefile.am
parent39537399a10dc27ac22a804e55d77d7160d1bd76 (diff)
downloadhdf5-5d954a0214fa92aec884cdbccab10632a925fc08.zip
hdf5-5d954a0214fa92aec884cdbccab10632a925fc08.tar.gz
hdf5-5d954a0214fa92aec884cdbccab10632a925fc08.tar.bz2
Squash commit of options to build tools and tests
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 10ef8c6..babbeee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -35,7 +35,7 @@ libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_
# H5Tinit.c and H5lib_settings.c are generated files and should be cleaned.
MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c
# H5pubconf.h is generated by configure, and should be cleaned.
-DISTCLEANFILES=H5pubconf.h
+DISTCLEANFILES=H5pubconf.h $(H5CC_NAME)
# library sources
libhdf5_la_SOURCES= H5.c H5checksum.c H5dbg.c H5system.c H5timer.c H5trace.c \
@@ -145,6 +145,8 @@ include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h H5vers
settingsdir=$(libdir)
settings_DATA=libhdf5.settings
+bin_SCRIPTS=$(H5CC_NAME)
+
# Number format detection
# The LD_LIBRARY_PATH setting is a kludge.
# Things should have been all set during H5detect making.
@@ -203,4 +205,10 @@ trace: $(libhdf5_la_SOURCES)
fi; \
done
+#install-exec-local:
+# @$(INSTALL) h5cc $(DESTDIR)$(bindir)/$(H5CC_NAME)
+#uninstall-local:
+# @$(RM) $(DESTDIR)$(bindir)/$(H5CC_NAME)
+
include $(top_srcdir)/config/conclude.am
+