summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-02-12 15:18:06 (GMT)
committerGitHub <noreply@github.com>2023-02-12 15:18:06 (GMT)
commita4e797b4d1ca9cdc8dd2d77cefa310647666c902 (patch)
tree213a494cbb142f21d5368ec126f28c66e73a99af /src/Makefile.am
parent35af1b0b7dcb7d0f3170e71aa016c404146aa8ae (diff)
downloadhdf5-a4e797b4d1ca9cdc8dd2d77cefa310647666c902.zip
hdf5-a4e797b4d1ca9cdc8dd2d77cefa310647666c902.tar.gz
hdf5-a4e797b4d1ca9cdc8dd2d77cefa310647666c902.tar.bz2
Bring generated file tidying from develop (#2451)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 507c727..ff4ec72 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -163,10 +163,11 @@ bin_SCRIPTS=$(H5CC_NAME)
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
H5Tinit.c: H5detect$(EXEEXT)
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
- sed -e 's/-L/:/g' -e 's/ //g'`" \
- $(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
- (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ @if $(AM_V_P); then set -x; else echo " GEN H5Tinit.c"; fi; \
+ LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+ sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
# Build configuration header file generation
@@ -175,10 +176,11 @@ H5Tinit.c: H5detect$(EXEEXT)
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
- sed -e 's/-L/:/g' -e 's/ //g'`" \
- $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
- (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ @if $(AM_V_P); then set -x; else echo " GEN H5lib_settings.c"; fi; \
+ LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+ sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
# Error header generation
@@ -205,7 +207,7 @@ $(top_srcdir)/src/H5overflow.h: $(top_srcdir)/src/H5overflow.txt
trace: $(libhdf5_la_SOURCES)
@for dep in $? dummy; do \
- if test $$dep != "dummy" -a -n "$(PERL)"; then \
+ if test $$dep != "dummy" -a -n "$(PERL)"; then \
case "$$dep" in \
*.c) \
$(TRACE) $$dep; \