summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-30 23:42:39 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-30 23:42:39 (GMT)
commit66af6dce17787f70e7bded57fdc63b1006ade754 (patch)
treeeb9ecc21bd4c265448324f9e192efac02fd841d8 /src/Makefile.am
parent70ddbda208079d6597e453b510f9bfa9320cf0bf (diff)
downloadhdf5-66af6dce17787f70e7bded57fdc63b1006ade754.zip
hdf5-66af6dce17787f70e7bded57fdc63b1006ade754.tar.gz
hdf5-66af6dce17787f70e7bded57fdc63b1006ade754.tar.bz2
[svn-r11319] Purpose:
Bug fixes Description: This checkin fixes an occasional error on kelgia on sol during distclean. It also causes test scripts to depend properly on the programs they're supposed to be testing. Solution: The kelgia bug was due to some files being cleaned by automake and manually. Removed the manual cleaning in src/Makefile.am. Test script dependencies now need to be specified manually, since the makefile can't guess what they test from their name. Currently all test scripts in a given directory have a single list of dependencies--this was easy and seems to be sufficient. These dependencies are listed in the SCRIPT_DEPEND variable in the Makefile.am. Platforms tested: heping, mir, modi4, sol Misc. update:
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7091120..37d1f54 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,13 +33,6 @@ lib_LTLIBRARIES=libhdf5.la
# Add libtool numbers to the HDF5 library (from config/lt_vers.am)
libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
-# Temporary files
-MOSTLYCLEANFILES=H5detect.o H5detect.lo H5detect H5Tinit.o H5Tinit.lo H5Tinit.c
-
-# libhdf5.settings is generated during configure. Remove it when distclean.
-DISTCLEAN=libhdf5.settings
-
-
# library sources
libhdf5_la_SOURCES= H5.c H5A.c H5AC.c H5B.c H5B2.c H5B2cache.c H5B2dbg.c \
H5B2test.c H5BP.c H5BPcache.c H5BPdbg.c H5BPtest.c \