summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2007-07-12 20:21:57 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2007-07-12 20:21:57 (GMT)
commita73ea1b4f06635fa712d93f3d956fbede0bd8294 (patch)
treed945f18cd2e2797ca7e881367d4ba86cf892ce79 /src/Makefile.am
parent1e91849e851e7b332bffc7dd1730f20f2eb17cd7 (diff)
downloadhdf5-a73ea1b4f06635fa712d93f3d956fbede0bd8294.zip
hdf5-a73ea1b4f06635fa712d93f3d956fbede0bd8294.tar.gz
hdf5-a73ea1b4f06635fa712d93f3d956fbede0bd8294.tar.bz2
[svn-r13969] Description:
Initial checkin of API version macro generation script (bin/make_vers), along with configuration file (src/H5vers.txt) and generated header (src/H5version.h). Right now, no version macros are defined, since the main source code and tests need to be adjusted to pay attention to the macros defined. Also, fixed makefile for generating error header files when used with GNU make. Tested on: Mac OS X/32 10.4.10 (amazon) Linux/32 2.6 (chicago) Linux/64 2.6 (chicago2)
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am29
1 files changed, 17 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1e593d2..bef62b6 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -89,29 +89,22 @@ libhdf5_la_SOURCES= H5.c H5checksum.c H5dbg.c H5system.c H5timer.c H5trace.c \
# Public headers
-include_HEADERS =H5public.h H5Apublic.h H5ACpublic.h \
- H5Cpublic.h H5Dpublic.h \
+include_HEADERS = hdf5.h H5api_adpt.h H5pubconf.h H5public.h H5version.h \
+ H5Apublic.h H5ACpublic.h \
+ H5Cpublic.h H5Dpublic.h \
H5Epubgen.h H5Epublic.h H5Fpublic.h H5FDpublic.h H5FDcore.h H5FDdirect.h \
H5FDfamily.h H5FDlog.h H5FDmpi.h H5FDmpio.h H5FDmpiposix.h \
H5FDmulti.h H5FDsec2.h H5FDstdio.h H5FDstream.h \
H5Gpublic.h H5Ipublic.h H5Lpublic.h \
H5MMpublic.h H5Opublic.h H5Ppublic.h H5Rpublic.h H5Spublic.h \
- H5Tpublic.h H5Zpublic.h H5pubconf.h hdf5.h H5api_adpt.h
+ H5Tpublic.h H5Zpublic.h
# install libhdf5.settings in lib directory
settingsdir=$(libdir)
settings_DATA=libhdf5.settings
-# Error header generation
-#
-# Actually, H5Einit.h, H5Eterm.h, H5Edefin.h and H5Epubgen.h all
-# depend on H5err.txt, but the perl script generates them all, so just
-# list one here.
-$(top_srcdir)/src/H5Edefin.h: $(top_srcdir)/src/H5err.txt
- perl $(top_srcdir)/bin/make_err $>
-
# Number format detection
-# The LD_LIBRARY_PATH setting is a klutch.
+# The LD_LIBRARY_PATH setting is a kludge.
# Things should have been all set during H5detect making.
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
@@ -122,6 +115,18 @@ H5Tinit.c: H5detect$(EXEEXT)
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
+# Error header generation
+#
+# Actually, H5Einit.h, H5Eterm.h, H5Edefin.h and H5Epubgen.h all
+# depend on H5err.txt, but the perl script generates them all, so just
+# list one here.
+$(top_srcdir)/src/H5Edefin.h: $(top_srcdir)/src/H5err.txt
+ perl $(top_srcdir)/bin/make_err $?
+
+# API version macro generation
+$(top_srcdir)/src/H5version.h: $(top_srcdir)/src/H5vers.txt
+ perl $(top_srcdir)/bin/make_vers $?
+
# Add TRACE macros to library source files. This is done via the trace script
# in the hdf5/bin directory. If the file contains HDF5 API macros, a "clean"
# version of the source file is saved with a tilde (~) after its name and