summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-03-30 18:55:41 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-03-30 18:55:41 (GMT)
commite1282224cdd7c05ef3c278b4e46b85fb59b2bc72 (patch)
tree6f92746cc6e4567669c706880497a6a7338d3281 /src/Makefile.am
parentabdfc0f817f84303b88410a5f5608a6655e45b8d (diff)
downloadhdf5-e1282224cdd7c05ef3c278b4e46b85fb59b2bc72.zip
hdf5-e1282224cdd7c05ef3c278b4e46b85fb59b2bc72.tar.gz
hdf5-e1282224cdd7c05ef3c278b4e46b85fb59b2bc72.tar.bz2
[svn-r18470] bug fix:
recent changes to the embedded library generation code does not quite work for the AIX system. The strings command of AIX does not display the embedded library information be default. Solution: Changed the H5libhhdf5_setting[] to be an extern variable. Also removed the const qualifier so that strings can see the variable data. Tested: Blue-print (with embedded-libinfo enabled and disabled).
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4d36f21..f370c98 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,7 @@ lib_LTLIBRARIES=libhdf5.la
libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
# H5Tinit.c is a generated file, and should be cleaned.
-MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.h
+MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c
# H5pubconf.h is generated by configure, and should be cleaned.
DISTCLEANFILES=H5pubconf.h
@@ -129,17 +129,17 @@ H5Tinit.c: H5detect$(EXEEXT)
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
-H5.o H5.lo: H5lib_settings.h
+H5.o H5.lo: H5lib_settings.c
# Build configuration header file generation
# The LD_LIBRARY_PATH setting is a kludge.
# Things should have been all set during H5make_libsettings making.
# Remove the generated .h file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
-H5lib_settings.h: H5make_libsettings$(EXEEXT) libhdf5.settings
+H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
sed -e 's/-L/:/g' -e 's/ //g'`" \
- $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > H5lib_settings.h || \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > H5lib_settings.c || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)