summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2009-10-23 20:11:11 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2009-10-23 20:11:11 (GMT)
commit663919aa50f3c1d270239e06794c3fc6fff1ad9f (patch)
treee216367ffb327004461dd832c46b10044979cd21 /src/Makefile.am
parent7fcd1375d81540e10f96c39d2ded53e34a3fe474 (diff)
downloadhdf5-663919aa50f3c1d270239e06794c3fc6fff1ad9f.zip
hdf5-663919aa50f3c1d270239e06794c3fc6fff1ad9f.tar.gz
hdf5-663919aa50f3c1d270239e06794c3fc6fff1ad9f.tar.bz2
[svn-r17738] Description:
Bring revisions 17649, 17657 and 17658 from trunk to 1.8 branch: 17649: Refactor v2 B-trees to pin the B-tree header in the cache instead of using separate reference counted data structure. 17657: Refactor the v2 B-tree code to use an open & close call internally, in preparation for making those part of the library private APIs for dealing with v2 B-trees. 17658: Rename 'H5B2_t' -> 'H5B2_hdr_t' and 'bt2' -> 'hdr' in preparation for make v2 B-tree open/close routines library private (instead of static). Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/default API=1.8.x, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (smirom) w/Intel compilers, w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, in production mode Linux/64-ia64 2.6 (cobalt) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-ia64 2.4 (tg-login3) w/parallel, w/FORTRAN, in debug mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in production mode Mac OS X/32 10.6.1 (amazon) in debug mode Mac OS X/32 10.6.1 (amazon) w/C++ & FORTRAN, w/threadsafe, in production mode
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ecf9cba..daf85c8 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,7 +44,7 @@ DISTCLEANFILES=H5pubconf.h
libhdf5_la_SOURCES= H5.c H5checksum.c H5dbg.c H5system.c H5timer.c H5trace.c \
H5A.c H5Abtree2.c H5Adense.c H5Adeprec.c H5Aint.c H5Atest.c \
H5AC.c H5B.c H5Bcache.c H5Bdbg.c \
- H5B2.c H5B2cache.c H5B2dbg.c H5B2int.c H5B2stat.c H5B2test.c \
+ H5B2.c H5B2cache.c H5B2dbg.c H5B2hdr.c H5B2int.c H5B2stat.c H5B2test.c \
H5C.c H5CS.c \
H5D.c H5Dbtree.c H5Dchunk.c H5Dcompact.c H5Dcontig.c H5Ddbg.c \
H5Ddeprec.c H5Defl.c H5Dfill.c H5Dint.c \