summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 19:52:37 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 19:52:37 (GMT)
commitdbb2eadcaa87a69c5c77e78c8db73df89821ca49 (patch)
treef3f6357a438b9cc010816226bfac7484c3621801 /src/Makefile.am
parent11f088a44c03fc1a49b95ef2adc5654932df597b (diff)
downloadhdf5-dbb2eadcaa87a69c5c77e78c8db73df89821ca49.zip
hdf5-dbb2eadcaa87a69c5c77e78c8db73df89821ca49.tar.gz
hdf5-dbb2eadcaa87a69c5c77e78c8db73df89821ca49.tar.bz2
[svn-r17572] Purpose:
Makefile Bug Fix Description: Added $(EXEEXT) extension to H5detect when it's executed to generate H5Tinit.c so it works correctly on platforms that require the full extension when running executables. Tested: h5committest, mingw, and user-verified (via submitted patch).
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 511c847..d7d0e15 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -123,7 +123,7 @@ settings_DATA=libhdf5.settings
H5Tinit.c: H5detect$(EXEEXT)
LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
sed -e 's/-L/:/g' -e 's/ //g'`" \
- $(RUNSERIAL) ./H5detect > H5Tinit.c || \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > H5Tinit.c || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)