summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNeil Fortner <nfortne2@hdfgroup.org>2013-09-19 18:57:41 (GMT)
committerNeil Fortner <nfortne2@hdfgroup.org>2013-09-19 18:57:41 (GMT)
commitbe3a33155025d6ef2d57533b60b96c888ab314a6 (patch)
tree2becf1264da71c35b6942b5858704f85cd8f189d /src/Makefile.am
parent0653325f0d4a92164842bb30b797f130e44cbc68 (diff)
downloadhdf5-be3a33155025d6ef2d57533b60b96c888ab314a6.zip
hdf5-be3a33155025d6ef2d57533b60b96c888ab314a6.tar.gz
hdf5-be3a33155025d6ef2d57533b60b96c888ab314a6.tar.bz2
[svn-r24171] Purpose: Fix problem with gcc 4.8
Description: With optimization enabled, gcc 4.8 inserts garbage into the padding bytes of floating point types when assigning from a literal constant. This caused problems when H5detect.c scanned the bits in floating point types to determine their properties. Modified H5detect.c to scan for padding before further analyzing the type, and to ignore all information in the padding areas. Also removed code that temporarily disabled optimization. Tested: jam, koala, ostrich, platypus (h5committest)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2d7640e..f63a36e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -27,7 +27,6 @@ include $(top_srcdir)/config/lt_vers.am
# a long time to compile it with any optimization on. H5detect is used
# to generate H5Tinit.c once. So, optimization is not critical.
noinst_PROGRAMS = H5detect H5make_libsettings
-H5detect_CFLAGS = $(AM_CFLAGS) -g -O0
# Our main target, the HDF5 library
lib_LTLIBRARIES=libhdf5.la