summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2010-03-31 23:06:18 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2010-03-31 23:06:18 (GMT)
commit21bd3532dd468eda3f32014fdc236d2a003f3521 (patch)
tree96b2dc42a6bc3c66f19407debe598783d4f10cc2 /src/Makefile.am
parent5d1838beab77a93f29ac0278ed43f9d1aec505b7 (diff)
downloadhdf5-21bd3532dd468eda3f32014fdc236d2a003f3521.zip
hdf5-21bd3532dd468eda3f32014fdc236d2a003f3521.tar.gz
hdf5-21bd3532dd468eda3f32014fdc236d2a003f3521.tar.bz2
[svn-r18474] Description:
Switch back to generating a .h file for the library settings. Also, tart it up a bit to avoid multiple inclusions, etc. Tested on: Mac OS X/32 10.6.3 (amazon) w/debug & production FreeBSD/32 6.3 (duty)
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 76d2e18..735cf9d 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,7 @@ lib_LTLIBRARIES=libhdf5.la
libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
# H5Tinit.c is a generated file, and should be cleaned.
-MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c
+MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.h
# H5pubconf.h is generated by configure, and should be cleaned.
DISTCLEANFILES=H5pubconf.h
@@ -134,17 +134,17 @@ H5Tinit.c: H5detect$(EXEEXT)
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
-H5.o H5.lo: H5lib_settings.c
+H5.o H5.lo: H5lib_settings.h
# Build configuration header file generation
# The LD_LIBRARY_PATH setting is a kludge.
# Things should have been all set during H5make_libsettings making.
# Remove the generated .h file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
-H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
+H5lib_settings.h: H5make_libsettings$(EXEEXT) libhdf5.settings
LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
sed -e 's/-L/:/g' -e 's/ //g'`" \
- $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > H5lib_settings.c || \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > H5lib_settings.h || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)