summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-29 17:38:17 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-29 17:38:17 (GMT)
commit7acf3f1b12cb743850f2ae4a13d67a080fc26793 (patch)
tree76ff86178b02b6329483b0975862032e73d1a991 /src/Makefile.am
parent9e4b79ad482c7fe41e893dac8f52b101fcdc38c3 (diff)
downloadhdf5-7acf3f1b12cb743850f2ae4a13d67a080fc26793.zip
hdf5-7acf3f1b12cb743850f2ae4a13d67a080fc26793.tar.gz
hdf5-7acf3f1b12cb743850f2ae4a13d67a080fc26793.tar.bz2
[svn-r10475] Purpose:
Feature - conditional compilation Description: SRB file driver and tests are now compiled only when SRB is enabled (using --with-srb during configure). Solution: Added an automake conditional in configure.in, altered Makefiles.am in src and test directories to depend on that conditional. This should make a nice example for posterity to add conditionally compiled sources. Platforms tested: heping (only configure change)
Diffstat (limited to 'src/Makefile.am')
-rwxr-xr-xsrc/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 40cd853..bdb7887 100755
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,7 +24,6 @@ include $(top_srcdir)/config/commence.am
# a long time to compile it with any optimization on. H5detect is used
# to generate H5Tinit.c once. So, optimization is not critical.
noinst_PROGRAMS = H5detect
-##H5detect_CFLAGS = -g $(AM_CFLAGS)
# Our main target, the HDF5 library
lib_LTLIBRARIES=libhdf5.la
@@ -35,6 +34,12 @@ MOSTLYCLEANFILES=H5detect.o H5detect.lo H5detect H5Tinit.o H5Tinit.lo H5Tinit.c
# libhdf5.settings is generated during configure. Remove it when distclean.
DISTCLEAN=libhdf5.settings
+# Compile SRB file driver only if SRB is enabled.
+if BUILD_SRB_CONDITIONAL
+ SRB_SOURCE=H5FDsrb.c
+ SRB_HEADER=H5FDsrb.h
+endif
+
# library sources
libhdf5_la_SOURCES= H5.c H5A.c H5AC.c H5B.c H5B2.c H5B2cache.c H5B2dbg.c \
H5B2test.c H5BT.c H5BTbtree2.c H5BTcache.c H5BTdbg.c H5BTtest.c H5C.c \
@@ -44,7 +49,7 @@ libhdf5_la_SOURCES= H5.c H5A.c H5AC.c H5B.c H5B2.c H5B2cache.c H5B2dbg.c \
H5Defl.c H5Dio.c H5Distore.c H5Dmpio.c H5Dselect.c H5Dtest.c H5E.c H5F.c \
H5Fdbg.c H5FD.c H5FDcore.c \
H5FDfamily.c H5FDfphdf5.c H5FDlog.c H5FDmpi.c H5FDmpio.c \
- H5FDmpiposix.c H5FDmulti.c H5FDsec2.c H5FDsrb.c H5FDstdio.c \
+ H5FDmpiposix.c H5FDmulti.c H5FDsec2.c $(SRB_SOURCE) H5FDstdio.c \
H5FDstream.c H5FL.c H5FO.c H5FP.c H5FPclient.c H5FPserver.c H5FS.c \
H5G.c H5Gent.c H5Gnode.c H5Gstab.c \
H5HG.c H5HGdbg.c H5HL.c H5HLdbg.c H5HP.c H5I.c H5MF.c H5MM.c H5O.c \
@@ -66,7 +71,7 @@ include_HEADERS =H5public.h H5Apublic.h H5ACpublic.h H5Bpublic.h H5B2public.h \
H5BTpublic.h H5Cpublic.h H5Dpublic.h \
H5Epubgen.h H5Epublic.h H5Fpublic.h H5FDpublic.h H5FDcore.h H5FDfamily.h \
H5FDfphdf5.h H5FDlog.h H5FDmpi.h H5FDmpio.h H5FDmpiposix.h \
- H5FDmulti.h H5FDsec2.h H5FDsrb.h H5FDstdio.h H5FDstream.h H5FPpublic.h \
+ H5FDmulti.h H5FDsec2.h $(SRB_HEADER) H5FDstdio.h H5FDstream.h H5FPpublic.h \
H5Gpublic.h H5HGpublic.h H5HLpublic.h H5Ipublic.h \
H5MMpublic.h H5Opublic.h H5Ppublic.h H5Rpublic.h H5Spublic.h \
H5Tpublic.h H5Zpublic.h H5pubconf.h hdf5.h H5api_adpt.h