summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-06-14 19:23:06 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-06-14 19:23:06 (GMT)
commitbb9370d777b645b9f0e2f5090421b63e207aa50f (patch)
tree932aa5b7867b332c854faed4e308abf4e265a5cf /src/Makefile.am
parentd5a8b2a80cd1e5aaa62a523e03a5936260a56f60 (diff)
parent57d5c207d94bf876c934094cc7193858590a2c9f (diff)
downloadhdf5-bb9370d777b645b9f0e2f5090421b63e207aa50f.zip
hdf5-bb9370d777b645b9f0e2f5090421b63e207aa50f.tar.gz
hdf5-bb9370d777b645b9f0e2f5090421b63e207aa50f.tar.bz2
Merge branch 'develop' into vol_dev_headers
Also moved the wrapper functions from the H5VLconnector.h to H5VLconnector_passthru.h
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0368739..73a8c83 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,10 +32,18 @@ lib_LTLIBRARIES=libhdf5.la
# Add libtool numbers to the HDF5 library (from config/lt_vers.am)
libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
+# h5cc needs custom install and uninstall rules, since it may be
+# named h5pcc if hdf5 is being built in parallel mode.
+if BUILD_PARALLEL_CONDITIONAL
+ H5CC_NAME=h5pcc
+else
+ H5CC_NAME=h5cc
+endif
+
# H5Tinit.c and H5lib_settings.c are generated files and should be cleaned.
MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c
# H5pubconf.h is generated by configure, and should be cleaned.
-DISTCLEANFILES=H5pubconf.h
+DISTCLEANFILES=H5pubconf.h $(H5CC_NAME)
# library sources
libhdf5_la_SOURCES= H5.c H5checksum.c H5dbg.c H5system.c H5timer.c H5trace.c \
@@ -152,6 +160,8 @@ include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h H5vers
settingsdir=$(libdir)
settings_DATA=libhdf5.settings
+bin_SCRIPTS=$(H5CC_NAME)
+
# Number format detection
# The LD_LIBRARY_PATH setting is a kludge.
# Things should have been all set during H5detect making.
@@ -210,4 +220,10 @@ trace: $(libhdf5_la_SOURCES)
fi; \
done
+#install-exec-local:
+# @$(INSTALL) h5cc $(DESTDIR)$(bindir)/$(H5CC_NAME)
+#uninstall-local:
+# @$(RM) $(DESTDIR)$(bindir)/$(H5CC_NAME)
+
include $(top_srcdir)/config/conclude.am
+