summaryrefslogtreecommitdiffstats
path: root/test/API/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-05-03 16:45:16 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2023-05-03 18:26:57 (GMT)
commit7df92eee39e904bb38e74ce5f7971ebc4886472b (patch)
treee15ab5693fa57f2a873173f1631d4515b77e6825 /test/API/CMakeLists.txt
parentc75b4af1a2630ace445da1ec661191601583f79a (diff)
downloadhdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.zip
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.gz
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.bz2
Changes to isolate API Test option files and use fetchcontent (#2880)
Diffstat (limited to 'test/API/CMakeLists.txt')
-rw-r--r--test/API/CMakeLists.txt38
1 files changed, 21 insertions, 17 deletions
diff --git a/test/API/CMakeLists.txt b/test/API/CMakeLists.txt
index d189d67..c2f95bd 100644
--- a/test/API/CMakeLists.txt
+++ b/test/API/CMakeLists.txt
@@ -9,26 +9,12 @@
# help@hdfgroup.org.
#
-#------------------------------------------------------------------------------
-# Set module path
-#------------------------------------------------------------------------------
-set(HDF5_TEST_API_CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/CMake")
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${HDF5_TEST_API_CMAKE_MODULE_PATH})
-
-# TODO: probably not necessary
-#------------------------------------------------------------------------------
-# Setup CMake Environment
-#------------------------------------------------------------------------------
-if (WIN32)
- message("The HDF5 API test suite is currently not supported on this platform." FATAL_ERROR)
-endif ()
+cmake_minimum_required (VERSION 3.18)
+project (HDF5_TEST_API C)
#------------------------------------------------------------------------------
# Setup testing configuration file
#------------------------------------------------------------------------------
-if (HDF5_TEST_PARALLEL)
- set (HDF5_TEST_API_HAVE_PARALLEL 1)
-endif ()
if (HDF5_TEST_API_ENABLE_ASYNC)
set (H5_API_TEST_HAVE_ASYNC 1)
endif ()
@@ -46,9 +32,27 @@ if (HDF5_TEST_API_ENABLE_DRIVER)
endif ()
#------------------------------------------------------------------------------
-# Setup for API tests
+# Define for API tests
#------------------------------------------------------------------------------
+set (HDF5_API_TESTS
+ attribute
+ dataset
+ datatype
+ file
+ group
+ link
+ misc
+ object
+)
+
+if (HDF5_TEST_API_ENABLE_ASYNC)
+ set (HDF5_API_TESTS
+ ${HDF5_API_TESTS}
+ async
+ )
+endif ()
+
# Ported HDF5 tests
set (HDF5_API_TESTS_EXTRA
testhdf5