summaryrefslogtreecommitdiffstats
path: root/test/API/CMakeLists.txt
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-11-15 14:20:50 (GMT)
committerGitHub <noreply@github.com>2023-11-15 14:20:50 (GMT)
commitc779464bfe3dabd767144526a868a5b06538161f (patch)
tree24dbf660c97b36d8634ce2cd8440cb2b61e3bcb3 /test/API/CMakeLists.txt
parente807dee0fd6c007d7c41327c1ed0e8f5bc617f72 (diff)
downloadhdf5-c779464bfe3dabd767144526a868a5b06538161f.zip
hdf5-c779464bfe3dabd767144526a868a5b06538161f.tar.gz
hdf5-c779464bfe3dabd767144526a868a5b06538161f.tar.bz2
Add GitHub actions for testing VOL connectors (#3849)
* Fix issue with HDF5_VOL_ALLOW_EXTERNAL CMake variable * Add initial API test workflow * Initialize parallel testing with MPI_THREAD_MULTIPLE when testing API * Add CMake variable to allow specifying a VOL connector's package name * Remove call to MPI_Init in serial API tests While previously necessary, it now interferes with VOL connectors that may need to be initialized with MPI_THREAD_MULTIPLE
Diffstat (limited to 'test/API/CMakeLists.txt')
-rw-r--r--test/API/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/API/CMakeLists.txt b/test/API/CMakeLists.txt
index 6f6af47..9495acd 100644
--- a/test/API/CMakeLists.txt
+++ b/test/API/CMakeLists.txt
@@ -141,7 +141,7 @@ target_compile_options (
target_compile_definitions (
h5_api_test
PRIVATE
- "$<$<CONFIG:Developer>:${HDF5_DEVELOPER_DEFS}>"
+ "${HDF5_TEST_COMPILE_DEFS_PRIVATE}"
)
# Always prefer linking the shared HDF5 library by default
if (BUILD_SHARED_LIBS)