summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-11-07 15:36:41 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-11-07 15:36:41 (GMT)
commitd33038cf0c09a9299fb955c9f5234805e8d81e49 (patch)
tree1d65ebeaad9a6c83c6adfaec6ba2880e9f035ffe /test/CMakeLists.txt
parent25e3b32d125a58785bd2f8026c45f44a2c861134 (diff)
downloadhdf5-d33038cf0c09a9299fb955c9f5234805e8d81e49.zip
hdf5-d33038cf0c09a9299fb955c9f5234805e8d81e49.tar.gz
hdf5-d33038cf0c09a9299fb955c9f5234805e8d81e49.tar.bz2
TRILABS: Merge CMake changes from develop
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2aedc82..ce39506 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -62,6 +62,7 @@ endif ()
#################################################################################
# If filter plugin tests can be tested
#################################################################################
+if (BUILD_SHARED_LIBS)
# make plugins dir
file (MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/filter_plugin_dir1")
file (MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/filter_plugin_dir2")
@@ -127,6 +128,7 @@ endif ()
"${CMAKE_BINARY_DIR}/filter_plugin_dir2/$<TARGET_FILE_NAME:${HDF5_TEST_PLUGIN_TARGET}>"
)
endforeach ()
+endif ()
#################################################################################
# Test program sources