summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-09 13:53:25 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-09 13:53:25 (GMT)
commitf1a668a3b5c8e35979f78e419ba76bee3cce78a9 (patch)
tree6044e325dfc0052bbc12fd4d8e01cfab7d3e0eaa /test/CMakeLists.txt
parent4069936ee48296216758a69cd5baccc04401c7b9 (diff)
downloadhdf5-f1a668a3b5c8e35979f78e419ba76bee3cce78a9.zip
hdf5-f1a668a3b5c8e35979f78e419ba76bee3cce78a9.tar.gz
hdf5-f1a668a3b5c8e35979f78e419ba76bee3cce78a9.tar.bz2
Correct COMPILE defs usage
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 166fd99..8badf3c 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -45,7 +45,7 @@ if (BUILD_SHARED_LIBS)
INTERFACE "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
)
target_compile_definitions(${HDF5_TEST_LIBSH_TARGET}
- PUBLIC "H5_BUILT_AS_DYNAMIC_LIB" $<$<BOOL:${HDF5_ENABLE_THREADSAFE}>:"H5_HAVE_THREADSAFE">
+ PUBLIC "H5_BUILT_AS_DYNAMIC_LIB" $<$<BOOL:${HDF5_ENABLE_THREADSAFE}>:H5_HAVE_THREADSAFE>
)
TARGET_C_PROPERTIES (${HDF5_TEST_LIBSH_TARGET} SHARED)
target_link_libraries (${HDF5_TEST_LIBSH_TARGET}