summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVailin Choi <vchoi@jam.ad.hdfgroup.org>2018-12-28 22:49:11 (GMT)
committerVailin Choi <vchoi@jam.ad.hdfgroup.org>2018-12-28 22:49:11 (GMT)
commitf808c108ed0315f115a7c69cbd8ee95032a64b34 (patch)
tree8f196f0f849958019b496027e00a87ed79b0d119 /test/CMakeLists.txt
parentba095e6a53a919c9753463c3800a26b180b7a135 (diff)
downloadhdf5-f808c108ed0315f115a7c69cbd8ee95032a64b34.zip
hdf5-f808c108ed0315f115a7c69cbd8ee95032a64b34.tar.gz
hdf5-f808c108ed0315f115a7c69cbd8ee95032a64b34.tar.bz2
Fix for HDFFV-10659: The library abort with "infinite loop closing library"
after deleting attributes in densed storage. The fix: When deleting attribute nodes from the name index v2 B-tree, if an attribute is found in the intermediate B-tree nodes, which may be merged/redistributed in the process, we need to free the dynamically allocated spaces for the intermediate decoded attribute.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ed6bacc..a82fe82 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -374,6 +374,7 @@ set (H5_CHECK_TESTS
atomic_reader
links_env
filenotclosed
+ del_many_dense_attrs
flushrefresh
)