summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-03-06 17:26:48 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-03-06 17:26:48 (GMT)
commitdbd93b2c552a58353ec5af7fb4067e1f1e1b17dd (patch)
tree41e587ee238f661529042afaeb7c4f0a9d0cbc72 /test/CMakeLists.txt
parent110d933a5720f4d9ad84cee8eac0ada7e8ffc956 (diff)
downloadhdf5-dbd93b2c552a58353ec5af7fb4067e1f1e1b17dd.zip
hdf5-dbd93b2c552a58353ec5af7fb4067e1f1e1b17dd.tar.gz
hdf5-dbd93b2c552a58353ec5af7fb4067e1f1e1b17dd.tar.bz2
[svn-r23332] HDFFV-8322: for valgrind testing, split-up testhdf5 tests by excluding and running long running tests separately.
Tested: local linux
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d0fcef9..6af1e94 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -225,7 +225,7 @@ ADD_TEST (
)
IF (HDF5_ENABLE_USING_MEMCHECKER)
- ADD_TEST (NAME testhdf5-base COMMAND $<TARGET_FILE:testhdf5> -x heap file select)
+ ADD_TEST (NAME testhdf5-base COMMAND $<TARGET_FILE:testhdf5> -x heap -x file -x select)
SET_TESTS_PROPERTIES(testhdf5-base PROPERTIES DEPENDS h5test-clear-testhdf5-objects)
SET_TESTS_PROPERTIES(testhdf5-base PROPERTIES ENVIRONMENT HDF5_ALARM_SECONDS=3600)
ADD_TEST (NAME testhdf5-heap COMMAND $<TARGET_FILE:testhdf5> -o heap)