summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2016-12-18 08:58:46 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2016-12-18 08:58:46 (GMT)
commit104253575dcc7e78c9a52e039028a90a2027896a (patch)
treebca97507bc045711c64f41474f3e59ddc588614f /test/CMakeLists.txt
parentf01ee3c00485d3a925924f134160c65908bb2d74 (diff)
downloadhdf5-104253575dcc7e78c9a52e039028a90a2027896a.zip
hdf5-104253575dcc7e78c9a52e039028a90a2027896a.tar.gz
hdf5-104253575dcc7e78c9a52e039028a90a2027896a.tar.bz2
Update CMake configuration files with SWMR accumulator changes.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5a55616..0197524 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -196,7 +196,6 @@ MACRO (ADD_H5_EXE file)
ENDMACRO (ADD_H5_EXE file)
set (H5_TESTS
- #testhdf5
cache
cache_api
cache_tagging
@@ -211,7 +210,6 @@ set (H5_TESTS
fheap
pool
accum
- #hyperslab
istore
bittests
dt_arith
@@ -234,7 +232,6 @@ set (H5_TESTS
app_ref
enum
set_extent
- #ttsafe
enc_dec_plist
enc_dec_plist_cross_platform
getname
@@ -328,6 +325,21 @@ foreach (test ${H5_CHECK_TESTS})
ADD_H5_EXE(${test})
endforeach (test ${H5_CHECK_TESTS})
+#-- Adding test for accum_swmr_reader
+# This has to be copied to the test directory for execve() to find it
+# and it can't be renamed (i.e., no <foo>-shared).
+add_executable (accum_swmr_reader ${HDF5_TEST_SOURCE_DIR}/accum_swmr_reader.c)
+TARGET_NAMING (accum_swmr_reader STATIC)
+TARGET_C_PROPERTIES (accum_swmr_reader STATIC " " " ")
+target_link_libraries (accum_swmr_reader ${HDF5_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
+set_target_properties (accum_swmr_reader PROPERTIES FOLDER test)
+
+#-- Set accum dependencies
+set_target_properties (accum PROPERTIES DEPENDS accum_swmr_reader)
+if (BUILD_SHARED_LIBS)
+ set_target_properties (accum-shared PROPERTIES DEPENDS accum_swmr_reader)
+endif (BUILD_SHARED_LIBS)
+
#-- Adding test for libinfo
set (GREP_RUNNER ${PROJECT_BINARY_DIR}/GrepRunner.cmake)
file (WRITE ${GREP_RUNNER}