summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-11-06 21:45:58 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-11-06 21:45:58 (GMT)
commit79903575e64e1e8f46ce27e6212d5d5939a8a900 (patch)
tree17ec3c8424b8f42ab67328cd2fd029dd3a0a0c3d /test/CMakeLists.txt
parentc77d044dd0af2dfcbf6369cf6975f36f0a28cd76 (diff)
downloadhdf5-79903575e64e1e8f46ce27e6212d5d5939a8a900.zip
hdf5-79903575e64e1e8f46ce27e6212d5d5939a8a900.tar.gz
hdf5-79903575e64e1e8f46ce27e6212d5d5939a8a900.tar.bz2
HDFFV-10605 Only test plugins if SHARED enabled
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 959bac8..ed6bacc 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -62,6 +62,7 @@ endif ()
#################################################################################
# If filter plugin tests can be tested
#################################################################################
+if (BUILD_SHARED_LIBS)
# make plugins dir
file (MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/filter_plugin_dir1")
file (MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/filter_plugin_dir2")
@@ -159,6 +160,7 @@ endif ()
"${CMAKE_BINARY_DIR}/vol/$<TARGET_FILE_NAME:${HDF5_VOL_PLUGIN_LIB_TARGET}>"
)
endforeach ()
+endif ()
#################################################################################
# Test program sources