summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-09-19 14:32:13 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-09-19 14:32:13 (GMT)
commit3117ffcbb40a88e41b2f3d28bc3c60eeb04d7499 (patch)
tree1daef21c11f57505c3f335746e9a6ecaefdfc006 /test/CMakeLists.txt
parentc3db70aff482b9315b59016e7dc5875a0285a2ed (diff)
downloadhdf5-3117ffcbb40a88e41b2f3d28bc3c60eeb04d7499.zip
hdf5-3117ffcbb40a88e41b2f3d28bc3c60eeb04d7499.tar.gz
hdf5-3117ffcbb40a88e41b2f3d28bc3c60eeb04d7499.tar.bz2
[svn-r22788] HDFFV-8153: Pull POSIX_C_SOURCE define out to separate variable. Use ADD_DEFINITIONS (${HDF5_EXTRA_C_FLAGS}) in non-fortran CMakeLists.txt folders
Tested: local
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 36d6ca4..d6ffe42 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -2,6 +2,11 @@ cmake_minimum_required (VERSION 2.8.6)
PROJECT (HDF5_TEST)
#-----------------------------------------------------------------------------
+# Apply Definitions to compiler in this directory and below
+#-----------------------------------------------------------------------------
+ADD_DEFINITIONS (${HDF5_EXTRA_C_FLAGS})
+
+#-----------------------------------------------------------------------------
# Define Sources
#-----------------------------------------------------------------------------
SET (TEST_LIB_SRCS