summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2011-06-23 16:40:31 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2011-06-23 16:40:31 (GMT)
commit6e55bfba8a8c203aa0b06638de3655cf823b954e (patch)
treea008dc7c5b7939576713d4ef779c1b86f7053fa4 /test/CMakeLists.txt
parentb5fbe95269323490a89f6d580a215c4763c18a2a (diff)
downloadhdf5-6e55bfba8a8c203aa0b06638de3655cf823b954e.zip
hdf5-6e55bfba8a8c203aa0b06638de3655cf823b954e.tar.gz
hdf5-6e55bfba8a8c203aa0b06638de3655cf823b954e.tar.bz2
[svn-r21024] Bug fix for Issue 2598 - In v1.6 library, there was EOA for the whole MULTI file saved in the
super block. We took it out in v1.8 library because it's meaningless for the MULTI file. v1.8 library saves the EOA for the metadata file, instead. But this caused some backward compatibility problem. v1.8 library couldn't open the file created with v1.6 library. I fixed the problem by checking the EOA value to detect the file created with v1.6 library. Tested on jam, koala, and linew.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 7685886..ad2547e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -93,6 +93,8 @@ SET (HDF5_REFERENCE_TEST_FILES
le_extlink1.h5
le_extlink2.h5
mergemsg.h5
+ multi_file_v16-r.h5
+ multi_file_v16-s.h5
noencoder.h5
specmetaread.h5
tarrold.h5
@@ -222,6 +224,8 @@ ADD_TEST (
extlinks19B00027.h5
extlinks19B00028.h5
fheap.h5
+ new_multi_file_v16-r.h5
+ new_multi_file_v16-s.h5
objcopy_ext.h5
sys_file1
tattr.h5