summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-02-21 19:58:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-02-21 19:58:09 (GMT)
commit78bce9b4b389b0f78d8200bc257a76dcb7380b49 (patch)
tree18cc387afd8f0f37c334c17ca9e48e68d6c4d92b /test/CMakeLists.txt
parent13edfb217585eee6fe9f9f20d0b3198c1bb5af98 (diff)
downloadhdf5-78bce9b4b389b0f78d8200bc257a76dcb7380b49.zip
hdf5-78bce9b4b389b0f78d8200bc257a76dcb7380b49.tar.gz
hdf5-78bce9b4b389b0f78d8200bc257a76dcb7380b49.tar.bz2
[svn-r20128] Add fortran mod folder to INCLUDE_DIRS for gfortran 4.2.x.
Add test dependicies to correct the order of tests - cmake 2.8.4 bug - but also will improve cmake parallel testing. Tested: local linux, jam
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d68e661..98ecf9b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -293,9 +293,11 @@ SET (H5_TESTS
)
FOREACH (test ${H5_TESTS})
- ADD_H5_TEST(${test})
+ ADD_H5_TEST(${test})
+ SET_TESTS_PROPERTIES(${test} PROPERTIES DEPENDS h5test-clear-objects)
ENDFOREACH (test ${H5_TESTS})
+SET_TESTS_PROPERTIES(flush2 PROPERTIES DEPENDS flush1)
##############################################################################
##############################################################################