summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-08-25 15:35:40 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-08-25 15:35:40 (GMT)
commita4c02d63503ab4c416ce1995590ca68f60abe8cf (patch)
tree4f34d4c3f1872f542977f45f2adb83a17037e9f0 /test/CMakeLists.txt
parent8f0169c6e93d921c060ae8e5781ed89383a6bf4f (diff)
downloadhdf5-a4c02d63503ab4c416ce1995590ca68f60abe8cf.zip
hdf5-a4c02d63503ab4c416ce1995590ca68f60abe8cf.tar.gz
hdf5-a4c02d63503ab4c416ce1995590ca68f60abe8cf.tar.bz2
[svn-r21311] add variables and commands to create libhdf5.settings. Add option to enable embedded strings. Add test to grep for string.
Trunk cycle passed and verified on windows.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aaf5dc2..54e699c 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -440,6 +440,20 @@ ADD_TEST (NAME links_env COMMAND "${CMAKE_COMMAND}"
)
SET_TESTS_PROPERTIES(links_env PROPERTIES DEPENDS h5test-clear-links_env-objects)
+#-- Adding test for libinfo
+SET (GREP_RUNNER ${PROJECT_BINARY_DIR}/GrepRunner.cmake)
+FILE (WRITE ${GREP_RUNNER}
+ "FILE (STRINGS \${TEST_PROGRAM} TEST_RESULT REGEX \"SUMMARY OF THE HDF5 CONFIGURATION\")
+IF (\${TEST_RESULT} STREQUAL \"0\")
+ MESSAGE (FATAL_ERROR \"Failed: The output: \${TEST_RESULT} of \${TEST_PROGRAM} did not contain SUMMARY OF THE HDF5 CONFIGURATION\")
+ELSE (\${TEST_RESULT} STREQUAL \"0\")
+ MESSAGE (STATUS \"COMMAND Result: \${TEST_RESULT}\")
+ENDIF (\${TEST_RESULT} STREQUAL \"0\")
+"
+)
+
+ADD_TEST (NAME testlibinfo COMMAND ${CMAKE_COMMAND} -D "TEST_PROGRAM=$<TARGET_FILE:${HDF5_LIB_TARGET}>" -P "${GREP_RUNNER}")
+
##############################################################################
##############################################################################
### V F D T E S T S ###