summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-04-01 21:04:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-04-01 21:04:06 (GMT)
commitad4154cdc89ddf15691dbfe1c609898ef484808b (patch)
tree19a59cc99175477756b58395d6d57aba7d2687f0 /test/CMakeLists.txt
parent025d90f57313002ddb6ac24dcb034baed1f39012 (diff)
downloadhdf5-ad4154cdc89ddf15691dbfe1c609898ef484808b.zip
hdf5-ad4154cdc89ddf15691dbfe1c609898ef484808b.tar.gz
hdf5-ad4154cdc89ddf15691dbfe1c609898ef484808b.tar.bz2
[svn-r26700] Generators are only built static
Plugin test for disable state does not print error stack and does not print FAILED
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c949560..c402324 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -296,8 +296,8 @@ endif (\${TEST_RESULT} STREQUAL \"0\")
##############################################################################
if (BUILD_SHARED_LIBS)
add_executable (plugin ${HDF5_TEST_SOURCE_DIR}/plugin.c)
- TARGET_NAMING (plugin ${LIB_TYPE})
- TARGET_C_PROPERTIES (plugin ${LIB_TYPE} " " " ")
+ TARGET_NAMING (plugin SHARED)
+ TARGET_C_PROPERTIES (plugin SHARED " " " ")
target_link_libraries (plugin ${HDF5_TEST_PLUGIN_LIB_TARGET})
set_target_properties (plugin PROPERTIES FOLDER test)
endif (BUILD_SHARED_LIBS)