summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVailin Choi <vchoi@jam.ad.hdfgroup.org>2019-01-06 15:25:48 (GMT)
committerVailin Choi <vchoi@jam.ad.hdfgroup.org>2019-01-06 15:25:48 (GMT)
commit489f6fb69711ef7f26f4c13ad863438779f654b8 (patch)
tree847210b7d0b62f1259ba1ea98bc72ff8369ccb36 /test/CMakeLists.txt
parent906479d3978adabbacb59da8ec7ffb85d0ddfc2f (diff)
downloadhdf5-489f6fb69711ef7f26f4c13ad863438779f654b8.zip
hdf5-489f6fb69711ef7f26f4c13ad863438779f654b8.tar.gz
hdf5-489f6fb69711ef7f26f4c13ad863438779f654b8.tar.bz2
Fix for HDFFV-10659: The library aborts with "infinite loop closing library"
after deleting attributes in densed storage. The fix: When deleting attribute nodes from the name index v2 B-tree, if an attribute is found in the intermediate B-tree nodes, which may be merged/redistributed in the process, we need to free the dynamically allocated spaces for the intermediate decoded attribute.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index ce39506..fa303ed 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -342,6 +342,7 @@ set (H5_CHECK_TESTS
atomic_reader
links_env
filenotclosed
+ del_many_dense_attrs
flushrefresh
)