summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSongyu Lu <songyulu@hdfgroup.org>2019-07-26 20:01:40 (GMT)
committerSongyu Lu <songyulu@hdfgroup.org>2019-07-26 20:01:40 (GMT)
commit59d7db40a72142b9027748e762f4b2e8038aefa9 (patch)
treed5fb56fd03d0ac0c607c9b4a9606a41ee8b721c6 /test/CMakeLists.txt
parent308393a020bd7a812c231eee8130c9365d192e18 (diff)
downloadhdf5-59d7db40a72142b9027748e762f4b2e8038aefa9.zip
hdf5-59d7db40a72142b9027748e762f4b2e8038aefa9.tar.gz
hdf5-59d7db40a72142b9027748e762f4b2e8038aefa9.tar.bz2
HDFFV-10658: setting and getting properties in API context. Porting the changes to the develop branch into the 1.10 branch: mainly the external file prefix and VDS prefix.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5b34ec5..f5a6b60 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -14,12 +14,14 @@ set (TEST_LIB_SOURCES
${HDF5_TEST_SOURCE_DIR}/h5test.c
${HDF5_TEST_SOURCE_DIR}/testframe.c
${HDF5_TEST_SOURCE_DIR}/cache_common.c
+ ${HDF5_TEST_SOURCE_DIR}/external_common.c
${HDF5_TEST_SOURCE_DIR}/swmr_common.c
)
set (TEST_LIB_HEADERS
${HDF5_TEST_SOURCE_DIR}/h5test.h
${HDF5_TEST_SOURCE_DIR}/cache_common.h
+ ${HDF5_TEST_SOURCE_DIR}/external_common.h
${HDF5_TEST_SOURCE_DIR}/swmr_common.h
)
@@ -208,6 +210,7 @@ set (H5_TESTS
extend
direct_chunk # compression lib link
external
+ external_env
efc
objcopy
links
@@ -235,6 +238,7 @@ set (H5_TESTS
freespace
mf
vds
+ vds_env
file_image
unregister
cache_logging