summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2013-05-06 20:51:26 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2013-05-06 20:51:26 (GMT)
commit8ec42ced8063d739ec6c3d656b0556c3aafbc395 (patch)
tree39c0e72f6d25b16ee346b15d698a8cd26702733a /test/CMakeLists.txt
parent8f3aee85de3d7202e82379647f8411258e7321fb (diff)
downloadhdf5-8ec42ced8063d739ec6c3d656b0556c3aafbc395.zip
hdf5-8ec42ced8063d739ec6c3d656b0556c3aafbc395.tar.gz
hdf5-8ec42ced8063d739ec6c3d656b0556c3aafbc395.tar.bz2
[svn-r23675] Issue 8380 - H5Zunregister caused seg fault. This is the followup commit. Quincey
reviewed my previous commit and suggested me to use H5I_iterate to iterate through all opened objects in H5Z_unregister. I changed it in this commit. Tested with h5committest.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8904fee..766ed7b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -397,6 +397,8 @@ ADD_TEST (
testmeta.h5
tstint1.h5
tstint2.h5
+ unregister_filter_1.h5
+ unregister_filter_2.h5
)
SET (H5_TESTS
@@ -453,6 +455,7 @@ SET (H5_TESTS
file_image
enc_dec_plist
enc_dec_plist_with_endianess
+ unregister
)
FOREACH (test ${H5_TESTS})
@@ -728,6 +731,7 @@ IF (HDF5_TEST_VFD)
tcheck_version
testmeta
links_env
+ unregister
)
IF (DIRECT_VFD)