summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJan-Willem Blokland <J.W.S.Blokland@XS4All.nl>2020-12-02 17:52:09 (GMT)
committerGitHub <noreply@github.com>2020-12-02 17:52:09 (GMT)
commitbf0cbcbea5043fccc1915f8d8b113729accd382a (patch)
treebf31b4f62a7e2499639b2801b9f452222a2136fe /test/CMakeLists.txt
parentc7c1046d492eb3c956868a66a5a66f814808838b (diff)
downloadhdf5-bf0cbcbea5043fccc1915f8d8b113729accd382a.zip
hdf5-bf0cbcbea5043fccc1915f8d8b113729accd382a.tar.gz
hdf5-bf0cbcbea5043fccc1915f8d8b113729accd382a.tar.bz2
(fix) Segmentation fault when using a compound type. (#143)
* (fix) Segmentation fault when using a compound type. In the case when a compounded attribute is written to dataset followed by writing the data with a data transform function to the dataset will result in a segmentation fault. It turns out the data is classified as compounded while it is not. Now, the state is always reset first to not compounded followed by the existing check if the variable is compounded. * (fix) Removed undesired comment lines. * (fix) Segmentation fault when using a compound type: added test. * (fix) Added the missing cmpd_transform.c file to MANIFEST. * (fix) cmpd_dtransform test: autotools and source header. Added the cmp_dtransform test to the autotools configuration and updated the HDF Group copyright header. Co-authored-by: Jan-Willem Blokland <Jan-Willem.Blokland@Shell.com>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 4cfe8c9..697ce8d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -332,6 +332,7 @@ set (H5_TESTS
thread_id # special link
vol
timer
+ cmpd_dtransform
)
macro (ADD_H5_EXE file)