summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-05-03 16:45:16 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2023-05-03 18:26:57 (GMT)
commit7df92eee39e904bb38e74ce5f7971ebc4886472b (patch)
treee15ab5693fa57f2a873173f1631d4515b77e6825 /test/CMakeLists.txt
parentc75b4af1a2630ace445da1ec661191601583f79a (diff)
downloadhdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.zip
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.gz
hdf5-7df92eee39e904bb38e74ce5f7971ebc4886472b.tar.bz2
Changes to isolate API Test option files and use fetchcontent (#2880)
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt24
1 files changed, 4 insertions, 20 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d52beb0..fe52cd3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -395,24 +395,6 @@ if (HDF5_BUILD_UTILS)
set (H5_TESTS ${H5_TESTS} mirror_vfd)
endif ()
-set (HDF5_API_TESTS
- attribute
- dataset
- datatype
- file
- group
- link
- misc
- object
-)
-
-if (HDF5_TEST_API_ENABLE_ASYNC)
- set (HDF5_API_TESTS
- ${HDF5_API_TESTS}
- async
- )
-endif ()
-
macro (ADD_H5_EXE file)
add_executable (${file} ${HDF5_TEST_SOURCE_DIR}/${file}.c)
target_include_directories (${file} PRIVATE "${HDF5_SRC_INCLUDE_DIRS};${HDF5_SRC_BINARY_DIR};${HDF5_TEST_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
@@ -897,8 +879,10 @@ if (HDF5_ENABLE_FORMATTERS)
clang_format (HDF5_TEST_use_disable_mdc_flushes_FORMAT use_disable_mdc_flushes)
endif ()
-add_subdirectory (API)
-
if (HDF5_TEST_SERIAL)
include (CMakeTests.cmake)
endif ()
+
+if (HDF5_TEST_API)
+ add_subdirectory (API)
+endif ()