summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2019-08-28 15:08:12 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2019-08-28 15:08:12 (GMT)
commite06bf9d263f46360e271569cd59a83786d80d7b6 (patch)
tree4ce0d2a63e6caf3f24c3fa7f34b4baa4c35c4619 /test/CMakeLists.txt
parent506a5069a8b401db52ffe314e53751a0f1027128 (diff)
downloadhdf5-e06bf9d263f46360e271569cd59a83786d80d7b6.zip
hdf5-e06bf9d263f46360e271569cd59a83786d80d7b6.tar.gz
hdf5-e06bf9d263f46360e271569cd59a83786d80d7b6.tar.bz2
HDFFV-10677 and HDFFV-10661
Description: - Added functions to query chunk information: H5Dget_num_chunks(dset_id, fspace_id, *nchunks) Gets the number of written chunks that intersect with the given dataspace. However, in this version, the intersection is not yet completed. Thus, the number of all written chunks will be returned. H5Dget_chunk_info_by_coord(dset_id, *offset, *filter_mask, *addr, *size) Given a chunk's logical coordinates, returns the chunk's filter, address, and size. H5Dget_chunk_info(dset_id, fspace_id, index, *offset, *filter_mask, *addr, *size) Given a chunk's index, returns the chunk's logical coordinates, filter, address, and size. The chunk belongs to a set of chunks that have nonempty intersection with the specified dataspace. However, in this version, the intersection is not yet completed, and the index is of all the written chunks. These functions comply with VOL. - Fixed some oversights found in the library for the tests in chunk_info.c to work correctly. The returned value from a callback function was not checked in H5EA_iterate(), H5FA_iterate(), and H5D__none_idx_iterate(). This oversight caused a callback function to continue iterating even though it's supposed to stop. Platforms tested: Linux/64 (jelly) Linux/64 (platypus) Darwin (osx1011test)
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index cbd1901..c1ac44c 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -242,6 +242,7 @@ set (H5_TESTS
page_buffer
dtypes
dsets
+ chunk_info
cmpd_dset
filter_fail
extend