summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-03-01 20:09:40 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-03-01 20:09:40 (GMT)
commit77dedb3c64efeb1636696f6ab19163f66986aac4 (patch)
tree5f9725fe138a355dbd904699bd4115a09c54bc8d /test/CMakeLists.txt
parent00eea738d6e6ff9ad237e6a3b652baac3c6d6845 (diff)
downloadhdf5-77dedb3c64efeb1636696f6ab19163f66986aac4.zip
hdf5-77dedb3c64efeb1636696f6ab19163f66986aac4.tar.gz
hdf5-77dedb3c64efeb1636696f6ab19163f66986aac4.tar.bz2
[svn-r23322] HDFFV-8322: Close resources, found from valgrind testing
Tested: local linux
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index aa92371..b830bc4 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -225,6 +225,9 @@ ADD_TEST (
)
ADD_TEST (NAME testhdf5 COMMAND $<TARGET_FILE:testhdf5>)
SET_TESTS_PROPERTIES(testhdf5 PROPERTIES DEPENDS h5test-clear-testhdf5-objects)
+IF (HDF5_ENABLE_USING_MEMCHECKER)
+ SET_TESTS_PROPERTIES(testhdf5 PROPERTIES ENVIRONMENT HDF5_ALARM_SECONDS=3600)
+ENDIF (HDF5_ENABLE_USING_MEMCHECKER)
##############################################################################
##############################################################################