summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-03-15 18:28:37 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-03-15 18:28:37 (GMT)
commit2923f64c28650e55833dd9d9a088dd7c4804e3e8 (patch)
treebbf4f0e68aa231c4dd38665a4d4301fc77e76b24 /test/CMakeLists.txt
parentc1ddb82ac1d160d59d32f9a012dbffd11911292b (diff)
downloadhdf5-2923f64c28650e55833dd9d9a088dd7c4804e3e8.zip
hdf5-2923f64c28650e55833dd9d9a088dd7c4804e3e8.tar.gz
hdf5-2923f64c28650e55833dd9d9a088dd7c4804e3e8.tar.bz2
[svn-r23357] HDFFV-8338: Add cmake support, this commit only tested for linux
Tested: local linux
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6af1e94..d104978 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -7,6 +7,21 @@ PROJECT (HDF5_TEST)
ADD_DEFINITIONS (${HDF5_EXTRA_C_FLAGS})
#-----------------------------------------------------------------------------
+# If plugin library tests can be tested
+#-----------------------------------------------------------------------------
+IF (BUILD_SHARED_LIBS)
+ IF (EXISTS "${HDF5_TEST_SOURCE_DIR}/plugin_lib" AND IS_DIRECTORY "${HDF5_TEST_SOURCE_DIR}/plugin_lib")
+ ADD_SUBDIRECTORY (${HDF5_TEST_SOURCE_DIR}/plugin_lib ${PROJECT_BINARY_DIR}/plugin_lib)
+ ENDIF (EXISTS "${HDF5_TEST_SOURCE_DIR}/plugin_lib" AND IS_DIRECTORY "${HDF5_TEST_SOURCE_DIR}/plugin_lib")
+ELSE (BUILD_SHARED_LIBS)
+ MESSAGE (STATUS " **** Plugins libraries must be built as shared libraries **** ")
+ ADD_TEST (
+ NAME H5PLUGIN-SKIPPED
+ COMMAND ${CMAKE_COMMAND} -E echo "SKIP H5PLUGIN TESTING"
+ )
+ENDIF (BUILD_SHARED_LIBS)
+
+#-----------------------------------------------------------------------------
# Define Sources
#-----------------------------------------------------------------------------
SET (TEST_LIB_SRCS