summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-10-14 22:52:13 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-10-14 22:52:13 (GMT)
commitbcf3f797d442096d4ec5fcbe009b20b84b1adc85 (patch)
treeb8148c7861e75841758a4a173c89979e8de8b06e /test/Makefile.am
parent1199296120cab95a4ef8de64538d8be3a44b9efe (diff)
downloadhdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.zip
hdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.tar.gz
hdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.tar.bz2
[svn-r11566] Purpose:
Makefile bug fix Description: Previously, automake didn't output rules to build perform/mpi-perf or the test/gen_* programs. Now these can be built by typing 'make mpi-perf' (or 'make foo') or by configuring with --enable-build-all. Solution: Automake doesn't like having rules for programs it doesn't build. Tricked it by having these programs built "sometimes"--whenever the user enables --build-all. This should be used mostly for testing and to ensure that these helper programs compile. ***IMPORTANT*** These programs do *not* currently compile. When --enable-build-all is used (not the default), gen_new_fill fails because it uses an old API. This is an existing "bug" that has simply been exposed by this checkin. Platforms tested: sleipnir, modi4, sol Misc. update:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index cb5eb38..365d5be 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -47,6 +47,21 @@ TEST_PROG=testhdf5 lheap ohdr stab gheap btree2 cache b+tree blocktrack sheap \
check_PROGRAMS=$(TEST_PROG) error_test err_compat testmeta
+# These programs generate test files for the tests. They don't need to be
+# compiled every time we want to test the library. However, putting
+# them in a conditional causes automake to generate rules so that they
+# can be built by hand. They can also be built by specifying
+# --enable-build-all at configure time.
+if BUILD_ALL_CONDITIONAL
+ BUILD_ALL_PROGS=gen_deflate gen_filters gen_new_array gen_new_fill \
+ gen_new_mtime gen_new_super gen_noencoder gen_nullspace \
+ gen_old_array gen_old_layout gen_old_mtime
+else
+ BUILD_ALL_PROGS=
+endif
+
+noinst_PROGRAMS=$(BUILD_ALL_PROGS)
+
# The libh5test library provides common support code for the tests.
noinst_LTLIBRARIES=libh5test.la
libh5test_la_SOURCES=h5test.c testframe.c