summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2009-09-28 15:44:35 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2009-09-28 15:44:35 (GMT)
commit06a71c86a3079e5acaa175898728a47c6e21e53c (patch)
tree4e28001017f05a1485dd1f1a22a2060c1bd94eee /test/Makefile.am
parent541f147c9110ca8a3692ff1253770e5fa54a1bff (diff)
downloadhdf5-06a71c86a3079e5acaa175898728a47c6e21e53c.zip
hdf5-06a71c86a3079e5acaa175898728a47c6e21e53c.tar.gz
hdf5-06a71c86a3079e5acaa175898728a47c6e21e53c.tar.bz2
[svn-r17542] New test:
Add new tests (tcheck_version, testcheck_version.sh) to verify H5check_version() does issue warnings and abort accordingly. Tests: H5committed tested plus jam serial tested.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fbd921a..7362872 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -24,7 +24,7 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_builddir)/src
# Test script for error_test and err_compat
-TEST_SCRIPT = testerror.sh testlibinfo.sh
+TEST_SCRIPT = testerror.sh testlibinfo.sh testcheck_version.sh
check_SCRIPTS = $(TEST_SCRIPT)
SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT)
@@ -46,10 +46,11 @@ TEST_PROG=testhdf5 lheap ohdr stab gheap cache cache_api \
# List programs to be built when testing here. error_test and err_compat are
# built at the same time as the other tests, but executed by testerror.sh.
+# tcheck_version is used by testcheck_version.sh.
# 'make check' doesn't run them directly, so they are not included in TEST_PROG.
# Also build testmeta, which is used for timings test. It builds quickly,
# and this lets automake keep all its test programs in one place.
-check_PROGRAMS=$(TEST_PROG) error_test err_compat testmeta
+check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta
# These programs generate test files for the tests. They don't need to be