summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSongyu Lu <songyulu@hdfgroup.org>2019-04-09 21:20:19 (GMT)
committerSongyu Lu <songyulu@hdfgroup.org>2019-04-09 21:20:19 (GMT)
commit477dda3c0daea39cdf409684e7dad0fd9367dd45 (patch)
tree08f8d1653aec4e356fb069ae3a7d8768009901e2 /test/Makefile.am
parentd8ff8da46cb49098c41b421427967eb736e15236 (diff)
downloadhdf5-477dda3c0daea39cdf409684e7dad0fd9367dd45.zip
hdf5-477dda3c0daea39cdf409684e7dad0fd9367dd45.tar.gz
hdf5-477dda3c0daea39cdf409684e7dad0fd9367dd45.tar.bz2
HDFFV-10658 - setting and getting properties in API context:
1. switched to use the existing H5F_prefix_open_t for enum type; 2. put the common private function used by external.c and external_env.c into external_common.c
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 68b9394..55b5a88 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -63,7 +63,7 @@ TEST_PROG= testhdf5 \
flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \
enc_dec_plist_cross_platform getname vfd ntypes dangle dtransform \
reserved cross_read freespace mf vds file_image unregister \
- cache_logging cork swmr vol
+ cache_logging cork swmr vol_tst
# List programs to be built when testing here.
# error_test and err_compat are built at the same time as the other tests, but executed by testerror.sh.
@@ -135,7 +135,7 @@ else
noinst_LTLIBRARIES=libh5test.la
endif
-libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c
+libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c
# Use libhd5test.la to compile all of the tests
LDADD=libh5test.la $(LIBHDF5)