summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2010-11-18 19:11:51 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2010-11-18 19:11:51 (GMT)
commit64a7862ffef32f17f8ec6632c201c99a233f419f (patch)
tree4a8dc9f80c0b8f6b72a955ba89cad501079034a0 /test/Makefile.am
parent116391d56a1142b08c4c02eb13ed8e4598af507b (diff)
downloadhdf5-64a7862ffef32f17f8ec6632c201c99a233f419f.zip
hdf5-64a7862ffef32f17f8ec6632c201c99a233f419f.tar.gz
hdf5-64a7862ffef32f17f8ec6632c201c99a233f419f.tar.bz2
[svn-r19824] 1. Made fixes as in rev #19813 in trunk:
a) Add comments to test_4() in test/external.c about the name "/ link". b) Fix one memory leak in src/H5Lexternal.c: free memory pointed to by tmp_env_prefix for HDF5_EXT_PREFIX case. 3. Made changes for bug #1930 as in rev #19783, #19781 in trunk. 4. Made corresponding CMake changes as in rev #19782 in trunk.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b37ad53..4493f4f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -24,9 +24,9 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_builddir)/src
# Test script for error_test and err_compat
-TEST_SCRIPT = testerror.sh testlibinfo.sh testcheck_version.sh
+TEST_SCRIPT = testerror.sh testlibinfo.sh testcheck_version.sh testlinks_env.sh
check_SCRIPTS = $(TEST_SCRIPT)
-SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT)
+SCRIPT_DEPEND = error_test$(EXEEXT) err_compat$(EXEEXT) links_env$(EXEEXT)
# These are our main targets. They should be listed in the order to be
@@ -50,7 +50,7 @@ TEST_PROG=testhdf5 lheap ohdr stab gheap cache cache_api \
# 'make check' doesn't run them directly, so they are not included in TEST_PROG.
# Also build testmeta, which is used for timings test. It builds quickly,
# and this lets automake keep all its test programs in one place.
-check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta
+check_PROGRAMS=$(TEST_PROG) error_test err_compat tcheck_version testmeta links_env
# These programs generate test files for the tests. They don't need to be
@@ -133,6 +133,6 @@ testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \
tvlstr.c tvltypes.c
# Temporary files.
-DISTCLEANFILES=testerror.sh testlibinfo.sh testcheck_version.sh
+DISTCLEANFILES=testerror.sh testlibinfo.sh testcheck_version.sh testlinks_env.sh
include $(top_srcdir)/config/conclude.am