summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2013-06-14 20:52:54 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2013-06-14 20:52:54 (GMT)
commit6e46183e3580866e77bccc2021707ac40d95fa52 (patch)
treeba7c3159f6113601ef443b664028fe6cfe41588a /test/Makefile.am
parentd01b40e43956e8494b7b536c8cca6246b81fe887 (diff)
downloadhdf5-6e46183e3580866e77bccc2021707ac40d95fa52.zip
hdf5-6e46183e3580866e77bccc2021707ac40d95fa52.tar.gz
hdf5-6e46183e3580866e77bccc2021707ac40d95fa52.tar.bz2
[svn-r23774] The standalone writer & reader tests that check atomic read-write operation on the system.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 397d20f..50060eb 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -51,7 +51,7 @@ TEST_PROG= testhdf5 lheap ohdr stab gheap cache cache_api cache_tagging \
bin_PROGRAMS=swmr_generator swmr_reader swmr_writer swmr_remove_reader \
swmr_remove_writer swmr_addrem_writer swmr_sparse_reader swmr_sparse_writer \
- use_append_chunk use_append_mchunks
+ use_append_chunk use_append_mchunks atomic_writer atomic_reader
# List programs to be built when testing here. error_test and err_compat are
# built at the same time as the other tests, but executed by testerror.sh.
@@ -162,7 +162,7 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 compact_dataset.h5 dataset.h5 \
swmr_data.h5 use_append_chunk.h5 use_append_mchunks.h5 \
flushrefresh.h5 flushrefresh_VERIFICATION_START \
flushrefresh_VERIFICATION_CHECKPOINT1 flushrefresh_VERIFICATION_CHECKPOINT2 \
- flushrefresh_VERIFICATION_DONE
+ flushrefresh_VERIFICATION_DONE atomic_data
# Sources for testhdf5 executable
testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \