summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2019-11-13 17:49:15 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2019-11-13 17:49:15 (GMT)
commit943e601b1044256c26924b6bcca1b6d3de7b9914 (patch)
tree7fbdd9632145185a370a0c10ded769c951cbd16b /test/Makefile.am
parentc5b8f3db3b9be323b621cdd8204e247521df0192 (diff)
downloadhdf5-943e601b1044256c26924b6bcca1b6d3de7b9914.zip
hdf5-943e601b1044256c26924b6bcca1b6d3de7b9914.tar.gz
hdf5-943e601b1044256c26924b6bcca1b6d3de7b9914.tar.bz2
Straggler from previous commit: build and link the new .c files where I
moved some previously-static variables and functions that were causing unused-variable/function warnings.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 3a8a8a8..6a83585 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -135,7 +135,7 @@ else
noinst_LTLIBRARIES=libh5test.la
endif
-libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c
+libh5test_la_SOURCES=h5test.c testframe.c cache_common.c swmr_common.c external_common.c H5srcdir.c
# Use libhd5test.la to compile all of the tests
LDADD=libh5test.la $(LIBHDF5)
@@ -145,6 +145,12 @@ ttsafe_SOURCES=ttsafe.c ttsafe_dcreate.c ttsafe_error.c ttsafe_cancel.c \
ttsafe_acreate.c
cache_image_SOURCES=cache_image.c genall5.c
+#filter_plugin_SOURCES=filter_plugin.c H5srcdir.c
+
+vds_swmr_gen_SOURCES=vds_swmr_gen.c vds_swmr_common.c
+vds_swmr_writer_SOURCES=vds_swmr_writer.c vds_swmr_common.c
+vds_swmr_reader_SOURCES=vds_swmr_reader.c vds_swmr_common.c
+
VFD_LIST = sec2 stdio core core_paged split multi family
if DIRECT_VFD_CONDITIONAL
VFD_LIST += direct