summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJan-Willem Blokland <J.W.S.Blokland@XS4All.nl>2020-12-02 17:52:09 (GMT)
committerGitHub <noreply@github.com>2020-12-02 17:52:09 (GMT)
commitbf0cbcbea5043fccc1915f8d8b113729accd382a (patch)
treebf31b4f62a7e2499639b2801b9f452222a2136fe /test/Makefile.am
parentc7c1046d492eb3c956868a66a5a66f814808838b (diff)
downloadhdf5-bf0cbcbea5043fccc1915f8d8b113729accd382a.zip
hdf5-bf0cbcbea5043fccc1915f8d8b113729accd382a.tar.gz
hdf5-bf0cbcbea5043fccc1915f8d8b113729accd382a.tar.bz2
(fix) Segmentation fault when using a compound type. (#143)
* (fix) Segmentation fault when using a compound type. In the case when a compounded attribute is written to dataset followed by writing the data with a data transform function to the dataset will result in a segmentation fault. It turns out the data is classified as compounded while it is not. Now, the state is always reset first to not compounded followed by the existing check if the variable is compounded. * (fix) Removed undesired comment lines. * (fix) Segmentation fault when using a compound type: added test. * (fix) Added the missing cmpd_transform.c file to MANIFEST. * (fix) cmpd_dtransform test: autotools and source header. Added the cmp_dtransform test to the autotools configuration and updated the HDF Group copyright header. Co-authored-by: Jan-Willem Blokland <Jan-Willem.Blokland@Shell.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7f4edd4..35e53be 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -60,7 +60,7 @@ TEST_PROG= testhdf5 \
cache cache_api cache_image cache_tagging lheap ohdr \
stab gheap evict_on_close farray earray btree2 fheap \
pool accum hyperslab istore bittests dt_arith page_buffer \
- dtypes dsets chunk_info cmpd_dset filter_fail extend direct_chunk \
+ dtypes dsets chunk_info cmpd_dset cmpd_dtransform filter_fail extend direct_chunk \
external efc objcopy objcopy_ref links unlink twriteorder big mtime \
fillval mount \
flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \