summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2018-04-30 14:52:07 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2018-04-30 14:52:07 (GMT)
commit09b1106e39edc1d2fa7c92c9c8de57d8c01e4e71 (patch)
tree9b65ffe80986b70b82006f00a3e6a5d847841806 /test/Makefile.am
parentfa829e322ed44a67e2b3f2d6adf1306ad794859b (diff)
downloadhdf5-09b1106e39edc1d2fa7c92c9c8de57d8c01e4e71.zip
hdf5-09b1106e39edc1d2fa7c92c9c8de57d8c01e4e71.tar.gz
hdf5-09b1106e39edc1d2fa7c92c9c8de57d8c01e4e71.tar.bz2
First stage of moving H5DOread/write_chunk() to src/ and making
them H5D calls. * Moved H5DOread/write_chunk() to H5Dio.c and renamed to H5D*. * Moved the hl/test/test_dset_opt test to test/ and renamed to direct_chunk. * Moved the hl/test/dectris_hl_perf test to tools/test/perform and renamed to direct_write_perf. * Updated autotools and CMake files.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ab81f50..8f671ac 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -55,11 +55,12 @@ TEST_PROG= testhdf5 \
cache cache_api cache_image cache_tagging lheap ohdr stab gheap \
evict_on_close farray earray btree2 fheap \
pool accum hyperslab istore bittests dt_arith page_buffer \
- dtypes dsets cmpd_dset filter_fail extend external efc objcopy links unlink \
- twriteorder big mtime fillval mount flush1 flush2 app_ref enum \
- set_extent ttsafe enc_dec_plist enc_dec_plist_cross_platform\
- getname vfd ntypes dangle dtransform reserved cross_read \
- freespace mf vds file_image unregister cache_logging cork swmr
+ dtypes dsets cmpd_dset filter_fail extend direct_chunk external efc \
+ objcopy links unlink twriteorder big mtime fillval mount \
+ flush1 flush2 app_ref enum set_extent ttsafe enc_dec_plist \
+ enc_dec_plist_cross_platform getname vfd ntypes dangle dtransform \
+ reserved cross_read freespace mf vds file_image unregister \
+ cache_logging cork swmr
# List programs to be built when testing here.
# error_test and err_compat are built at the same time as the other tests, but executed by testerror.sh.
@@ -190,7 +191,7 @@ CHECK_CLEANFILES+=accum.h5 cmpd_dset.h5 compact_dataset.h5 dataset.h5 dset_offse
flushrefresh_VERIFICATION_DONE atomic_data accum_swmr_big.h5 ohdr_swmr.h5 \
test_swmr*.h5 cache_logging.h5 cache_logging.out vds_swmr.h5 vds_swmr_src_*.h5 \
swmr[0-2].h5 swmr_writer.out swmr_writer.log.* swmr_reader.out.* swmr_reader.log.* \
- tbogus.h5.copy cache_image_test.h5
+ tbogus.h5.copy cache_image_test.h5 direct_chunk.h5
# Sources for testhdf5 executable
testhdf5_SOURCES=testhdf5.c tarray.c tattr.c tchecksum.c tconfig.c tfile.c \